The Dutch HackInfo

Information about Hacking, Security & Tweaking

1 1 1 1 1 1 1 1 1 1 Rating 1.00 (1 Vote)
Een nieuw ontdekt beveiligingslek in talloze mediaspelers geeft hackers de mogelijkheid om op afstand systemen over te nemen. Het probleem zit in de manier waarop de Quicktime Library misvormde .MOV bestanden verwerkt. Bijna alle programma's die dit soort bestanden verwerken zijn kwetsbaar. Via een online verschenen exploit is het mogelijk om "geheugen corruptie" te veroorzaken, maar ook het uitvoeren van willekeurige code lijkt mogelijk. "Omdat dit probleem ook browsers raakt, lijkt het erop dat de aanvalsvector zowel lokaal als remote is", aldus 'Dr_IDE', de alias van de onderzoeker die het probleem ontdekte.

Zowel Mac OS X als Windows systemen zijn kwetsbaar. Op Mac OS X gaat het onder andere om iTunes, QuickTime, Safari, Garageband, Finder, Firefox, VLC, PowerPoint 2008 en Word 2008. Windows XP systemen met iTunes, QuickTimes en Media Player Classic lopen risico. Bij al deze programma's gaat het om de laatste versie. De VLC mediaspeler is op Windows niet kwetsbaar, wat ook gedeeltelijk voor Firefox 3.5.3 geldt. Het lukte de onderzoeker niet om de opensource browser op betrouwbare wijze te laten crashen. De advisory is op deze pagina te vinden, de exploit staat hier.

You have no rights to post comments


Copyright © 2019. All Rights Reserved.